Propeller C - Set Up SimpleIDE

(Updated 2013-08-08 for SimpleIDE 0.9.40 and its Learn folder's Simple Libraries and Examples - Propeller C Tutorial Archive)

About SimpleIDE

SimpleIDE is an open source programming tool for Propeller C.  It's designed to be easy for beginners to use, yet also includes features that experienced programmers will appreciate. 

This quick tutorial will help you:

  • Set up the latest version of SimpleIDE for your operating system
  • Get the latest Propeller C Tutorials libraries and example programs

Click on your system to get started

News Flash! Version 1.0 RC1 now available for testing on Windows, Mac and Linux.  (Updated 11/24/2014)

 


Notice for High School and University Information Technology Staff

SimpleIDE is the official programming interface for Parallax's Propeller C Educational program.  Like many modern software programs, SimpleIDE is an open source offering. Parallax maintains an official distribution branch of the project to be released as Parallax approved software on this website.  Parallax strives to keep the features and functions of this distribution of SimpleIDE in-line with the needs of educational institutions to provide a consistent and trustworthy user experience. SimpleIDE installers are available for Windows, Mac and Linux operating systems. 

No approval is required from Parallax to install the SimpleIDE software on your institution's computers. In fact, this is the intended audience for SimpleIDE. Please feel free to contact our educational team if you need any further verification on the subject.


MIT License

The C libraries for the Propeller C Tutorial program are offered under the MIT License.


Open Source Software Projects

Links for the two open-source software projects that make up the foundation of the Propeller C Tutorials are available below.


What's new in v1.0?

  • Enhanced COM port list to automatically update with virtual COM port events.
  • Added Help > Build Error Rescue feature to easily copy build status for sharing with others.
  • Added Tools > Update Workspace feature to simplify process of updating the user’s workspace with libraries released later.
  • Enhanced to replace missing Workspace subfolders from original set.
  • Context-sensitive help added for function names and libraries.
  • Added auto-main project maker for .c/.cpp files having main but no associated .side file.
  • Improved Linux and OS X installation experience.
  • Added USB Driver to installer where appropriate per platform.
  • Made the Build Status clear upon project creation and project loading.
  • Added features to lessen confusion when compiling with a non-project tab visible.
  • Enhanced load options to reopen terminal after programming.
  • Made the Find dialog’s Find button active by default.
  • Updated project manager to allow right-click shortcut menu even in blank area of view.
  • Removed “Welcome to Simple View” message.  Simple View is the default and is recommended for educational uses.  Project View is now available only after setting the “View Mode” option in the Tools > Properties > General tab.
  • Removed the legacy Add Library toolbar button from Simple View.
  • Removed dependency for libquazip.
  • Changed Mac shortcuts from F8...F11 to be Alt+F8...Alt+F11 because of conflict on Mac.
  • Fixed bug allowing leading/trailing whitespace in filenames that would break project compilation.
  • Fixed bug preventing linked file types in subfolders from showing assembly.
  • Fixed bug in terminal positioning feature.
  • Included Simple Library updates as of 11/07/2014.
  • SimpleIDE is now published according to the GPLv3 license.